Tipps, Tricks und Kniffe

Sammlung kurzer, hilfreicher Anleitungen, die kein eigenes Buch füllen.

Audio, Video

Audio, Video

Audiodateien komprimieren und umwandeln

Anwendungen wie PowerPoint, Audiorecorder und Smartphones erzeugen oft recht große Audiodateien. Um die Dateigröße bei gleichbleibender Qualität auf ein Minimum zu reduzieren, ist es meist sinnvoll, Audiodateien zu komprimieren. Komprimierte Audiodateien sind kleiner, vermindern Speicherplatzbedarf und Download-Zeiten.

Gelegentlich ist es notwendig, Audiodateien von einem Format in ein anderes zu umzuwandeln – z. B. von wav in mp4 oder umgekehrt. Auch dies ist mit dieser Anleitung möglich.

Video media player (VLC) ist ein kostenloser vielseitiger Media Player zum Abspielen und Konvertieren von Audio und Video. Er wird für alle gängigen Betriebssysteme angeboten.

Diese Anleitung beschreibt die Nutzung unter Windows.

Audioformate

Es gibt viele Audioformate. Die verbreitetsten sind

Für den gewöhnlichen Gebrauch eignet sich das mp4-Format am besten. Dessen Dateien haben die Endung .mp4 oder .m4a.

Schritt-für-Schritt-Anleitung

  1. Laden Sie VLC herunter, installieren und starten Sie das Programm.

    VLC Media Player

  2. Wählen Sie im Menü Medien > Konvertieren/Speichern  (Strg + R).
    image.png
  3. Ziehen Sie die zu komprimierende Datei (Video oder Audio) per Drag and Drop in die Dateiauswahlliste oder fügen Sie sie per + Hinzufügen hinzu.

    image.png

  4. Wählen Sie im Dropdown-Button Konvertieren (Alt + O).

    image.png

  5. Falls Sie zum ersten mal eine Audiodatei konvertieren oder noch kein Profil Audio - AAC existiert, müssen Sie im Abschnitt Einstellungen ein Neues Profil erstellen.  Anderenfalls springen Sie zu Punkt 7.

    image.png

  6. Nennen Sie das Profil "Audio - AAC" und wählen Sie  MP4/MOV als Verkapselung.

    image.png

  7. In der Registerkarte Audiocodec aktivieren Sie Audio und wählen den Codec MPEG 4 Audio (AAC). Für normales Audio ist eine Bitrate von 80kB/s eine gute Wahl. Üblicherweise benötigen Sie 2 Kanäle und eine Abtastrate von 48000 Hz. Speichern Sie das Profil mit Erstellen.

    image.png

  8. Wählen Sie das Profil "Audio - AAC" und mit Durchsuchen einen Speicherort. Vergeben Sie einen Dateinamen. Mit Start beginnt die Konvertierung.

    image.png

    image.png

Audio, Video

Videodateien komprimieren

Um die Dateigröße von Videodateien bei gleichbleibender Video-/Audioqualität auf ein Minimum zu reduzieren, ist es oft notwendig, Videos zu rekomprimieren. Technisch spricht man dabei von "encodieren". Die Re-Encodierung von Videos aus Anwendungen wie Screenrecordern, PowerPoint etc. ist in fast allen Fällen sinnvoll. Re-encodierte Videos sind oft deutlich kleiner als die Ausgangsdateien, vermindern den Speicherplatzbedarf und die Dauer von Übertragungen im Internet.

HandBrake ist eine freie Software, mit der Videos komprimiert, gekürzt, für Web optimiert, entrauscht und in der Anzeigegröße verkleinert werden können. Funktionen und Einstellungen sind gut dokumentiert.

Diese Anleitung beschreibt die Nutzung von HandBrake unter Windows.

Kurzanleitung

  1. Laden Sie HandBrake herunter, installieren und starten Sie es.
  2. Ziehen Sie die zu komprimierende Videodatei per Drag and Drop in den dafür vorgesehenen Bereich.

    Das Video wird geladen.HandBrake-drag-n-drop.png

  3. Nun sehen Sie in einer Vorschau Einzelbilder des Videos und eine Reihe von Optionen.

    HandBrake-Uebersicht.png

  4. Wählen Sie die Voreinstellung Fast 1080p30 aus. Mit ihr erzeugen Sie Videos in Full-HD-Auflösung, mit max. 30 Bildern pro Sekunde, sehr guter Audioqualität mit durchschnittlicher Dateigröße in akzeptabler Zeit. Für die meisten Anwendungsfälle ist dies ein guter Kompromiss.

    HandBrake-Voreinstellungen.png

  5. Starten Sie die Komprimierung mit Klick auf Encodierung starten.

    HandBrake-Encodierung.png

  6. In der Fußleiste sehen Sie die geschätzte, verbleibende Rechenzeit. Nach Abschluss des Encodings wird das Video im unter Speichern unter angegebenen Verzeichnis abgelegt. Üblicherweise ist dies der Ordner Video.

Erweiterte Einstellungen

Im Folgenden sind wichtige Einstellungen beschrieben, um Videos noch effizienter zu komprimieren. Durch geschickte Wahl lässt sich die Dateigröße abermals deutlich reduzieren.

Voreinstellungen, Bereich, Übersicht

Bildgröße

In dieser Registerkarte können stellen Sie Werte zu Ausgabegröße, Ausrichtung, Beschnitt, Seitenverhältnis etc. ein. In der Regel ist eine Änderung der Optionen weder notwendig noch empfehlenswert.

Filter

Die Wahl der Filter hat einen entscheidenden Einfluss auf Bildqualität und Dateigröße.

HandBrake-Filter.png

Video

Hier legen Sie fest, mit welcher Bitrate und mit wieviel Rechenleistung das Video encodiert werden soll. Prinzipiell gilt:

  1. Hohe Bitrate, hohe Qualität, große Datei
  2. Viel Rechenleistung, hohe Qualität, hoher Zeitaufwand zur Encodierung, kleine Datei

Für eine qualitativ hochwertiges Video bei geringer Dateigröße ist also etwas mehr Zeit zur Encodierung notwendig.

HandBrake-Video.png

Audio

Hier legen Sie fest, welche Audiospur wie encodiert werden soll. In der Regel werden ihre Ausgangsvideodateien nur eine Spur haben.

HandBrake-Audio.png

Warteschlange

Falls Sie mehrere Videos "in einem Rutsch" encodieren möchten, besteht die Möglichkeit, diese erst Zur Warteschlange hinzuzufügen. Mit Kick auf Warteschlange öffnet sich eine neues Fenster mit abgeschlossenen, in Bearbeitung befindlichen und anstehenden Aufgaben. Sie können die Bearbeitung pausieren, zu einem späteren Zeitpunkt fortsetzen oder beenden. Zudem ist es möglich, Videos aus der Warteschlange zurück ins Hauptfenster zu übertragen, um die vorgenommen Einstellungen aufzurufen und anzupassen.

HandBrake-Warteschlange.png

Audio, Video

Video aufnehmen

Opencast Studio

Sie können Video im Browser direkt über Moodle aufnehmen. Gehen Sie dazu in den Block Aufzeichnungen in Videocampus auf der rechten Seite. Ist der Block noch nicht vorhanden, fügen Sie ihn über Bearbeiten einschalten und Block hinzufügen ein.

Um einfach Videos aufzunehmen können Sie auch direkt Opencast Studio https://studio.opencast.org/ aufrufen. Diese Seite wird jedoch nicht vom Universitätsrechenzentrum betreut. Dies ist eine sehr einfache Möglichkeit, die ohne Softwareinstallation umgesetzt werden kann.

Opencast Studio im Moodle-Block

Klicken Sie auf Video im Browser aufzeichnen.

Bildschirmfoto 2023-09-13 um 13.41.44.png

Es öffnet sich eine neue Ansicht auf der Ihnen drei Auswahlmöglichkeiten zur Verfügung stehen. 

Wählen Sie den entsprechenden Modi aus und folgenden Sie den Anweisungen im Browser.

Bildschirmfoto 2023-09-13 um 13.45.56.png

Weiterhin empfehlen wir die kostenlose Open-Source-Software OBS Studio für Videoaufnahmen und Live-Streaming https://obsproject.com/de. Diese Software muss installiert werden. 

Bildbearbeitung

Bildbearbeitung

Bilder verkleinern

Fotos aus Kameras und Smartphones haben eine hohe Auflösungen und große Dateigröße. Zur Weiterverarbeitung wie z. B. zum Versand per E-Mail ist die Reduktion von Auflösung und Dateigröße auf das notwendige Minimum sinnvoll.

IrfanView ist eine kostenlose, mächtige Bildbearbeitungssoftware für Windows zum:

IrfanView ist ausschließlich für Windows verfügbar. Bevor Sie mit nachfolgenden Schritten beginnen, müssen Sie IrfanView herunterladen und installieren.

einzelnes Bild verkleinern

  1. Ziehen Sie ein Bild per Drag and Drop in IrfanView, laden es via Datei > Öffnen  oder drücken O.

    image.png

  2. Öffnen Sie die Bildinformationen via Bild > Informationen (I) . Sie sehen die aktuelle Größe sowie benötigter  Speicherplatz (Plattenplatz).

    image.png

  3. Über Bild > Größe ändern (Strg + R) öffnet sich ein Dialog, mit dem Sie die Größe ändern können. Wählen Sie 1920 x 1080 (FHD). Full HD (FHD) ist für die meisten Anwendungsfälle ausreichend. Bestätigen Sie mit OK.

    image.png

  4. Prüfen Sie wie unter 2. beschrieben die neue Bildgröße mit I.

    image.png

  5. Mit Datei > Speichern (S) können Sie das verkleinerte Bild abspeichern. Reduzieren Sie die Qualität auf das notwendige Minimum von 75 %, aktivieren Sie Als Progressives-JPEG speichern und Speichern sie das Bild ab.

    image.png

  6. Das entstandene Bild hat geringere Abmessungen und ist deutlich kleiner.

    image.png

mehrere Bilder verkleinern

Die Option, Bilder zu verkleinern lässt sich mit der Option, Bilder umzubenennen, kombinieren. Wählen Sie dazu in Schritt 3 Arbeite als: Batch-Konvertierung + Umbenennung.

  1. Öffnen Sie Datei > Batch(Stapel)-Konvertierung/Umbenennung oder drücken Sie B.
    image.png
  2. Ziehen Sie die Bilder per Drag and Drop in de untere Liste. Sie könne auch mehrere oder alle Dateien im oberen Fenster auswählen und über die Schaltfläche Hinzufügen oder Alle hinzufüg..

    image.png

  3. Wählen Sie im Bereich Arbeite als: Batch-Konvertierung. Im Optionen für Batch-Konvertierung: wählen Sie JPG - JPG/JPEG Format und aktivieren Spezial-Optionen aktiv (Größe ändern etc.).

    image.png

  4. In den Optionen für das Zielformat setzen Sie die Qualität auf 75, aktivieren Als Progressives-JPG speichern und bestätigen mit OK.

    image.png

  5. Nun Setzen Sie die Spezial-Optionen. Aktivieren Sie Größe ändern: und wählen Lange Seite setzen: mit 1920 Pixel. Proportional und 'Resample'-Funktion verwenden sind standardmäßig aktiv. Aktivieren Sie vorsichtshalber Kleine Bilder nicht vergrößern und bestätigen sie mit OK.

    image.png

  6. Wählen Sie das Zielverzeichnis. Das Zielverzeichnis muss sich vom Quellverzeichnis unterscheiden, da die Quelldateien nicht überschrieben werden. Das einfachste ist, Sie klicken auf Aktuelles Verzeichnis verwenden und ergänzen den neu gesetzten Pfad um einen neuen Unterordner hier: klein.